Excel

ZÄHLENWENN-Funktion effektiv anwenden

03.05.2021
Von 
Thomas Rieske arbeitet seit Oktober 2002 als freiberuflicher IT-Fachjournalist und Autor. Zu den Themenschwerpunkten des Diplom-Übersetzers zählen unter anderem Computersicherheit, Office-Anwendungen und Telekommunikation.
Wie oft kommt in einer Tabelle ein bestimmter Begriff oder eine bestimmte Zahl vor? Excel kann die Angabe mithilfe der Funktion „ZÄHLENWENN“ermitteln.

Die Funktion ermöglicht es, eine Tabelle oder einen Teilbereich davon nach bestimmten Schlagwörtern zu durchforsten. Zurückgeliefert wird immer die Anzahl der Treffer, die den Kriterien entsprechen. Die Funktion ist relativ einfach aufgebaut und akzeptiert zwei Argumente:

=ZÄHLENWENN(Suchbereich;Suchkriterium)

Mit dem Suchbereich geben Sie die Zellen an, in denen Excel für Sie die Suche durchführen soll. Dabei kann es sich um einzelne Zellen (zum Beispiel A1) oder zusammenhängende Bereiche (zum Beispiel A2:A10) handeln. Wenn Sie bei einer sehr großen Tabelle nicht wissen, wo sie endet, erfassen Sie beispielsweise mit A:A die gesamte Spalte A.

Mit dem Suchkriterium legen Sie fest, wonach Sie suchen. Das kann Text sein, etwa Schneider, wenn Sie - wie in unserem Beispiel einer fiktiven Personalliste - nach einem Namen suchen:

=ZÄHLENWENN(A2:A15; "Schneider")

Diese Formel liefert die Anzahl der Zellen im Bereich von A2 bis A15 zurück, in denen der Begriff Schneider vorkommt. Groß- und Kleinschreibung bleiben unberücksichtigt. Falls Sie die genaue Schreibweise eines Suchworts nicht kennen, können Sie auch Platzhalter verwenden. Das Fragezeichen steht hierbei für genau ein unbekanntes Zeichen, das Sternchen für beliebig viele. Mit dem folgenden Beispiel erhalten Sie die Zahl aller Personen im Suchbereich Ihrer Liste, deren Namen mit Sch beginnt:

=ZÄHLENWENN(A2:A15; "Sch*")

Möglich sind natürlich auch Zahlen inklusive Vergleichsoperatoren wie größer als (>) oder kleiner als (<). Achten Sie aber darauf, Zahlen ebenso wie Text in Anführungszeichen zu setzen:

=ZÄHLENWENN(D2:D15;">50000")

Hiermit lässt sich in unserer Beispielliste die Anzahl derjenigen ermitteln, deren Gehalt mehr als 50.000 Euro beträgt.

Die ZÄHLENWENN-Funktion kennt eine wesentliche Beschränkung: Mehr als ein Bereich und ein Suchkriterium sind nicht möglich. Häufig kommt es aber darauf an, mehrere Kriterien miteinander zu verknüpfen. An dieser Stelle kommt der große Bruder von ZÄHLENWENN ins Spiel: Die ZÄHLENWENNS-Funktion. Die allgemeine Syntax sieht folgendermaßen aus:

=ZÄHLENWENNS(Kriterienbereich1;Kriterien1;Kriterienbereich2;Kriterien2…)

Sie können bis zu 127 Bereichs-/Kriterienpaare verwenden. Es gilt aber zu berücksichtigen, dass jeder zusätzliche Bereich die gleiche Anzahl von Zeilen und Spalten wie der erste Kriterienbereich aufweisen muss.

Wenn Sie zum Beispiel wissen möchten, wie viele Beschäftigte auf unserer Personalliste in der IT-Abteilung arbeiten und ein Gehalt von mehr als 50.000 Euro beziehen, geben Sie Folgendes ein:

=ZÄHLENWENNS(C2:C15;"IT";D2:D15;">50000")

Falls Sie hier als zweiten Bereich beispielsweise D1:D15 statt D2:D15 eintragen, gibt Excel einen Fehler aus, weil der zweite Suchbereich um eine Zelle größer als der erste ist. (ad)