Microsoft Excel

Uhrzeiten auf Viertelstunden in Excel runden

20.02.2019
Von 
Thomas Rieske arbeitet seit Oktober 2002 als freiberuflicher IT-Fachjournalist und Autor. Zu den Themenschwerpunkten des Diplom-Übersetzers zählen unter anderem Computersicherheit, Office-Anwendungen und Telekommunikation.
Wer etwa seine Dienstleistungen zeitbasiert abrechnet, geht dabei selten minutengenau vor, sondern verwendet oft ein auf Viertelstunden basierendes Schema. Wenn Sie die Aufgabe Excel übertragen, benötigen Sie demzufolge eine Möglichkeit, entsprechend auf- oder abzurunden. Damit das reibungslos klappt, gibt es einiges zu beachten.

Excel-Problem beim Runden der Uhrzeit

Excel verfügt zwar seit geraumer Zeit über eine Runden-Funktion, behandelt aber Uhrzeiten intern in spezieller Form. Diese werden als Bruchteile von Zahlen gespeichert, wobei 1 für 24 Stunden steht. Anhand dieser Information ergeben sich bereits die grundlegenden Schritte für die anzuwendende Formel.

Excel-Uhrzeit auf Viertelstunde runden

Zunächst gilt es, die Uhrzeit per Multiplikation in Viertelstunden umzurechnen. Dann soll die Runden-Funktion diese Zahl auf die nächste Viertelstunde auf- beziehungsweise abrunden. Das Ergebnis muss man anschließend durch Division aber wieder in eine für Excel lesbare Uhrzeit umwandeln.

In folgendem Beispiel steht die Uhrzeit in Zelle A1. Diesen Wert multiplizieren Sie in der Nachbarzelle, etwa B1, mit 24 (ein Tag hat 24 Stunden) und anschließend mit 4 (jede Stunde besteht aus 4 Viertelstunden). Die Runden-Funktion rundet das Ergebnis auf die nächste Viertelstunde:

=RUNDEN(A1*24*24;0)

Die Null nach dem Semikolon sorgt für die Ausgabe ohne Nachkommastellen.

Konvertieren des Zeitwertes in eine Uhrzeit

Noch kann Excel damit allerdings nichts anfangen, denn es fehlt die Rückkonvertierung in eine Uhrzeit. Der gerundete Wert muss also erst durch das Ergebnis aus 24*4 dividiert werden:

=RUNDEN(A1*24*4;0) / (24*4)

Denken Sie an die Klammerung von 24*4, da sonst der gerundete Wert durch 24 geteilt und dann das Resultat mit 4 multipliziert wird. Um eine korrekte Anzeige zu erhalten, müssen Sie außerdem für Zelle B1 als Format Uhrzeit festlegen, was sich einfach über das Kontextmenü und den Befehl Zellen formatieren bewerkstelligen lässt.

Andere Rundungsparameter wählen

Ausgehend von dieser Formel können Sie natürlich auch auf einer anderen Basis runden, etwa auf zehn Minuten. Sie müssen lediglich den Faktor 4 gegen den Faktor 6 austauschen, da 1 Stunde aus 6*10 Minuten besteht:

=RUNDEN(A1*24*6;0) / (24*6)

(hal)