Ratgeber Excel

So rechnen Sie mit Excel-Funktionen

05.01.2016
Von 
Seine erste Berührung mit Informatik erfolgte an einem C64 samt Floppy VC 1541. Von Anfang an nutzte er diesen faszinierenden Heimcomputer nicht nur zum Daddeln, sondern auch für die Basic-Programmierung. Unter anderem half er seinen damals etwas müden Kopfrechnen-Fähigkeiten auf die Sprünge, indem er ein Programm schrieb, das immer zwei zufällig ausgewählte Zahlen zur Multiplikation stellte. Im Hintergrund lief ein Timer. Nur wenn er das Ergebnis innerhalb des vorgegebenen Zeitraums, der leider manchmal zu knapp bemessen war, richtig eintippte, bekam er einen Punkt gutgeschrieben. Seine Highscore-Ergebnisse waren durchwachsen, seine Programmierkenntnisse dafür umso besser. Der Lehrstuhl, an dem er als studentische Hilfskraft angestellt war, gehörte seinerzeit zu den Vorreitern in Sachen IT. Man übersetzte damals die griechischen Inschriften der antiken Stadt Hierapolis – heute ist dieses türkische Pamukkale bekannt durch seine Kalksinter-Terrassen. Die wissenschaftlich korrekt erfassten und kommentierten Inschriften bearbeiteten Dirscherl und Kollegen zunächst in Wordperfect. Anschließend landeten die Texte in einer Datenbank, die auf CD gepresst und für sündhaft viel Geld weltweit verkauft wurde. Über dieses epigraphische Datenbankprojekt, diverse C-Programmierereien auf Unix-Systemen und seine ersten Experimente mit Linux landete er schließlich professionell bei der IT. Seit den späten 1990-ern nutzt er Linux als Produktivsystem, seit Anfang der 2000-er Jahre ist Linux sein hauptsächliches OS. Nach vielen Jahren mit Suse Linux und Open Suse und zwischendurch Ausflügen zu Red Hat und Debian landete er bei Ubuntu und erledigt damit alle Arbeiten. Linux und C ist er bis heute treu geblieben – nach einem Ausflug zu PHP und MySQL. Mittlerweile bastelt er auch mit Arduino. Bei pcwelt.de betreut er vor allem Business-IT-Themen und hat den Auto & Technik-Bereich von Null beginnend aufgebaut. Seine Tests der Infotainmentsysteme in modernen Fahrzeugen gehören zu den ausführlichsten Tests, die man dazu überhaupt finden kann. Daneben schreibt er zudem fast täglich aktuelle Meldungen aus der IT-Welt.
Datenauswertung anhand eines einfachen Beispiels
Datenauswertung anhand eines einfachen Beispiels
Foto: IDG

SUMME ist natürlich kein sehr spektakulärer Vertreter der Funktionen. Die vielfältigen Möglichkeiten von Funktionen zeigen sich erst an einem etwas komplexeren Beispiel: Nehmen wir an, der Spielverein Obersee veranstaltete einen Spielnachmittag, bei dem alle Teilnehmenden Punkte sammelten. Zur Auswertung trägt Organisator Egon Müller zuerst Jahrgang, Name, Vorname und Geschlecht in eine Tabelle ein und in der letzten Spalte die erreichte Punktzahl.

ANZAHL zählt die Anzahl Einträge in einer Spalte. MITTELWERT ermitttelt den Durchschnitt.
ANZAHL zählt die Anzahl Einträge in einer Spalte. MITTELWERT ermitttelt den Durchschnitt.
Foto: IDG

An den folgenden Beispielen sehen Sie, wie einfach die Auswertung solcher Datensätze mit den von Excel bereitgestellten Funktionen ist.

Funktion ANZAHL

Leider hat Egon Müller vergessen, wie viele Leute am Spielnachmittag teilnahmen. Zugegeben: Wenige Teilnehmer könnte Müller einfach von Hand zählen, aber er benutzt lieber die Funktion ANZAHL. Müller möchte, dass die Anzahl der Teilnehmer in Zelle I2 erscheint. Als Bezug gilt für die Formel die Position des ersten und des letzten Wertes, der für ihn wichtig ist, im Beispiel A2 und A12. Die korrekte Formel muss also bei aktivierter Zelle 12 so aussehen: =ANZAHL(A2:A12). Das Ergebnis ist 11.

Funktion MITTELWERT

Als Nächstes will Müller in Zelle I3 wissen, wie alt die Teilnehmenden im Durchschnitt sind. Dafür eignet sich die Funktion MITTELWERT. Sie ermittelt den Durchschnitt der eingetragenen Daten. In Spalte A steht der Jahrgang der Mitspieler, folglich muss die Formel =MITTELWERT(A2:A12) lauten. Das Resultat ist leider unschön: 1969.81818.

=RUNDEN(I4;2), das Ergebnis 1969,82.
=RUNDEN(I4;2), das Ergebnis 1969,82.

Funktion RUNDEN

Dem begegnet Müller mit der Funktion RUNDEN. Im Gegensatz zum MITTELWERT verlangt RUNDEN einen so genannten Parameter, also eine weitere Anweisung. In diesem Fall ist es die Anzahl Stellen hinter dem Komma, die angezeigt werden sollen. Hat eine Funktion wie in diesem Fall mehr als einen Parameter, werden sie durch Strichpunkte (;) voneinander getrennt.

Manchmal ist es ratsam, den gerundeten Wert in einem separaten Feld (im Beispiel in Zelle J4) darzustellen, die Formel bezieht sich dann auf die Zelle, in der das ungerundete Resultat steht. Beim Runden auf zwei Stellen nach dem Komma ist der zusätzliche Parameter 2, die Formel in J4 lautet =RUNDEN(I3;2), das Ergebnis 1969,82.

Diese Form ist in unserem Beispiel allerdings nicht sehr schön, weil jetzt für dasselbe Resultat zwei Zellen benötigt werden (I3 und J4). Abhilfe schafft ein geschachtelter Befehl, in dem die Funktionen MITTELWERT und RUNDEN kombiniert werden. Jetzt wird es etwas komplizierter: Die erste Funktion RUNDEN bezieht sich auf die zweite Funktion MITTELWERT, die sich wiederum auf bestimmte Zellen bezieht.

Excel kann mehrere Funktionen verschachteln
Excel kann mehrere Funktionen verschachteln
Foto: IDG

Dementsprechend müssen Sie in der Formel Klammern setzen. Im Beispiel lautet die Formel =RUNDEN(MITTELWERT(A2:A12);0). Wenn mit dem Parameter 0 gerundet wird, also keine Nachkommastellen zugelassen sind, steht in Zelle I3 die Zahl 1970, weil 1969,81818 aufgerundet wird.