Microsoft Excel

Dubletten über mehrere Spalten hinweg ermitteln

28.06.2019
Von 
Thomas Rieske arbeitet seit Oktober 2002 als freiberuflicher IT-Fachjournalist und Autor. Zu den Themenschwerpunkten des Diplom-Übersetzers zählen unter anderem Computersicherheit, Office-Anwendungen und Telekommunikation.
Duplikate in einzelnen Spalten zu finden, ist mithilfe von bedingten Formatierungen schnell erledigt. Excel bringt dazu sogar eine eigene Regel mit. Doch wie muss man vorgehen, wenn nur doppelte Einträge in mehreren Spalten relevant sind, wie es etwa bei Adressen der Fall ist?

Welche Funktion nutzen?

Zu diesem Zweck gibt es in Excel die Funktion ZÄHLENWENNS. Deren allgemeine Syntax lautet: =ZÄHLENWENNS(Bereich 1; Kriterium 1; Bereich 2; Kriterium 2; ....).

Die Formel bestimmen

Als Beispiel wählen wir eine Adressliste, die von Spalte A bis Spalte E und von Zeile 2 bis Zeile 9 geht. In der ersten Zeile sind die Spaltenüberschriften untergebracht. Die Bereiche entsprechen hierbei den verschiedenen Spalten, das Kriterium dem Eintrag in der jeweiligen aktuellen Zeile. Somit ergibt sich folgende Formel:

=ZÄHLENWENNS($A$2:$A$9;$A2;$B$2:$B$9;$B2;$C$2:$C$9;$C2;$D$2:$D$9;$D2;$E$2:$E$9;$E2)

Die richtigen Bezüge

Diese Formel fügen wir in F2 ein und kopieren sie dann nach unten. Damit beim Kopieren die Bezüge stimmen, müssen Sie die Bereiche mit absoluten Bezügen angeben, zu erkennen am Dollar-Zeichen. Die Kriterien dürfen Sie wiederum nur mit gemischten Bezügen angeben, sodass die Spalte einen absoluten Bezug hat, die Zeilennummer jedoch nicht.

Was die Formel liefert

Die Zählenwenns-Funktion liefert eine Zahl zurück, die anzeigt, wie oft eine bestimmte Adresse in der Tabelle vorkommt. Entscheidend für eine Dublette ist aber lediglich, ob das Ergebnis größer als 1 ist. Eine Prüfung auf >1 komplettiert daher unsere Formel und liefert das Ergebnis Wahr (Dublette) oder Falsch (Keine Dublette).

Die Formatierungsregel anlegen

Damit ist alles vorhanden, um eine eigene bedingte Formatierungsregel anzulegen. Dazu markieren Sie die Tabelle ohne die Spaltenüberschriften und erstellen über Bedingte Formatierung / Neue Regel eine neue Formatierungsregel.

Das Ergebnis

Im folgenden Dialog markieren Sie unter Regeltyp den Eintrag Formel zur Ermittlung der zu formatierenden Zellen verwenden. Anschließend kopieren Sie Ihre Zählenwenns-Funktion in das Feld Werte formatieren, für die diese Formel wahr ist und bestätigen mit dem OK-Button. In der Adressliste werden jetzt die Dubletten entsprechend Ihrer festgelegten Formatierung hervorgehoben, etwa durch eine farbliche Markierung. (jd)