Ratgeber Excel

So rechnen Sie mit Excel-Funktionen

Seine erste Berührung mit Informatik erfolgte an einem C64 samt Floppy VC 1541. Von Anfang an nutzte er diesen faszinierenden Heimcomputer nicht nur zum Daddeln, sondern auch für die Basic-Programmierung. Unter anderem half er seinen damals etwas müden Kopfrechnen-Fähigkeiten auf die Sprünge, indem er ein Programm schrieb, das immer zwei zufällig ausgewählte Zahlen zur Multiplikation stellte. Im Hintergrund lief ein Timer. Nur wenn er das Ergebnis innerhalb des vorgegebenen Zeitraums, der leider manchmal zu knapp bemessen war, richtig eintippte, bekam er einen Punkt gutgeschrieben. Seine Highscore-Ergebnisse waren durchwachsen, seine Programmierkenntnisse dafür umso besser. Der Lehrstuhl, an dem er als studentische Hilfskraft angestellt war, gehörte seinerzeit zu den Vorreitern in Sachen IT. Man übersetzte damals die griechischen Inschriften der antiken Stadt Hierapolis – heute ist dieses türkische Pamukkale bekannt durch seine Kalksinter-Terrassen. Die wissenschaftlich korrekt erfassten und kommentierten Inschriften bearbeiteten Dirscherl und Kollegen zunächst in Wordperfect. Anschließend landeten die Texte in einer Datenbank, die auf CD gepresst und für sündhaft viel Geld weltweit verkauft wurde. Über dieses epigraphische Datenbankprojekt, diverse C-Programmierereien auf Unix-Systemen und seine ersten Experimente mit Linux landete er schließlich professionell bei der IT. Seit den späten 1990-ern nutzt er Linux als Produktivsystem, seit Anfang der 2000-er Jahre ist Linux sein hauptsächliches OS. Nach vielen Jahren mit Suse Linux und Open Suse und zwischendurch Ausflügen zu Red Hat und Debian landete er bei Ubuntu und erledigt damit alle Arbeiten. Linux und C ist er bis heute treu geblieben – nach einem Ausflug zu PHP und MySQL. Mittlerweile bastelt er auch mit Arduino. Bei pcwelt.de betreut er vor allem Business-IT-Themen und hat den Auto & Technik-Bereich von Null beginnend aufgebaut. Seine Tests der Infotainmentsysteme in modernen Fahrzeugen gehören zu den ausführlichsten Tests, die man dazu überhaupt finden kann. Daneben schreibt er zudem fast täglich aktuelle Meldungen aus der IT-Welt.
Formeln und Funktionen sind das stärkste Instrument in Excel. Auch komplizierte Berechnungen führen Sie mit Funktionen in Excel ruckzuck aus.

Die Tabellenkalkulation Microsoft Excel bietet weit über 300 Funktionen – von einfachen Rechenaufgaben wie z.B. eine Addition (Funktion SUMME) bis zu aufwändigen Auswertungen der Daten, bei der Werte verglichen werden (Funktion INDEX). Auf dieser Webseitestellt Microsoft alle vorhandenen Funktionen vor. Damit fällt auch der Umgang mit komplexen Datensätzen leicht – allerdings nur, wenn Sie wissen, wie Formeln und Funktionen in Excel grundsätzlich funktionieren.

Wir erklären die Funktionen von Excel anhand von Excel 2013, weil das neue Excel 2016 in den Büros noch nicht flächendeckend Einzug gehalten hat. Die hier vorgestellten Funktionen entsprechenden den Funktionen in Excel 2011 für Macintosh. Zudem sollten sämtliche hier vorgestellten Funktionen auch mit dem neuen Excel 2016 für Windows und Macintosh funktionieren.

Denn die wesentliche Neuerung von Excel 2016 gegenüber der Vorgängerversion sind die erweiterten Visualisierungsfunktionen. Wie sich Office 2016 speziell auf dem Mac macht, erklärt dieser Ratgeber. Fast alle Funktionen der Windows-Vorgängerversion Excel 2013 stehen jetzt auch auf dem Macintosh zur Verfügung.

Hier zeigt Ihnen Excel alle verfügbaren Funktionen an.
Hier zeigt Ihnen Excel alle verfügbaren Funktionen an.

Tipp:Sie können sich alle in Excel vorhandenen Funktionen anzeigen lassen, wenn Sie die Registerkarte "Formeln" wählen und dann die Schaltfläche „Funktion einfügen“ anklicken. In dem sich dann öffnenden Fenster wählen Sie bei „Kategorie auswählen“ „Alle“ aus. Dann zeigt Excel im Auswahlfenster darunter alle vorhandenen Funktionen an. Mit einem Mausklick bekommen Sie zu jeder Funktion eine kurze Beschreibung.

Formeln: Die Grundlage für Funktionen in Excel

Bevor wir zu den Excel-Funktionen wie SVERWEIS oder Matrixformeln kommen, erklären wir erst einmal deren Basis: Die Formeln.

Die Formel schreiben Sie immer in die Bearbeitungsleiste und sie beginnt immer mit einem Gleichzeichen (=). Ein einfaches Beispiel: Lassen Sie Excel das Resultat der Summe 113+253 berechnen. Sie klicken dazu auf eine beliebige Zelle, schreiben =113+253 in die Bearbeitungsleiste und drücken die Enter-Taste. Sofort wird das Resultat der Summe – 366 – in der zuvor angeklickten ("aktivierten") Zelle angezeigt.

Einfaches Beispiel einer Formel. Hilfe zur eingetippten Formel bietet ein Klick auf das Symbol ƒx
Einfaches Beispiel einer Formel. Hilfe zur eingetippten Formel bietet ein Klick auf das Symbol ƒx
Foto: IDG

Meistens ist es aber so, dass Sie mit Werten rechnen, die bereits in der Tabelle stehen. Sie geben keine Zahlen ein, sondern beschreiben lediglich, wo sie eingetragen sind. Dazu nutzen Sie das Koordinatensystem von Excel: Zeilen werden nach dem Schema 1,2,3 etc. nummeriert, Spalten mit A,B,C etc. alphabetisch angezeigt. Die Zelle ganz oben links ist also A1, die rechts davon B1 und die darunter A2 etc.

Links die Fornel =A1+A2, rechts das Ergebnis
Links die Fornel =A1+A2, rechts das Ergebnis

In obigen Screenshot steht in der Zelle A1 die Zahl 113, in A2 253. Für die Berechnung bezieht sich Excel auf Zellen, die Koordinaten A1 und A2 der Zellen heißen deshalb "Bezug". Die Formel, die wir für die Zelle A3 eintragen, lautet =A1+A2. Das angezeigte Resultat in A3 ist wieder 366.

Wenn Sie später Werte in der Tabelle verändern, werden Sie sehen, dass sich auch die Resultate Ihrer Formeln sofort anpassen. Bei komplexen Tabellen mit vielen Werten behalten Sie so die Übersicht. Ebenso bei Tabellen, die ständig aktualisiert werden. Sie nutzen Excel nicht mehr nur als Datenspeicher, sondern als komplexes Auswertungsprogramm für Ihre Daten.

Funktionen in Excel

Mit dieser Art der Formelnutzung wäre Excel aber nicht fähig, wirklich komplexe Berechnungen zu ermöglichen. Darum geht die Software noch einen Schritt weiter und bietet die so genannten Funktionen an. Ein Beispiel: Anstatt im obigen Beispiel =A1+A2 zu schreiben, sagen wir Excel einfach, was wir tun wollen: Wir brauchen die Summe. Fürs Addieren stellt Excel die gleichnamige Funktion SUMME zur Verfügung.

Das Ergebnis von =SUMME(A1:A2 sehen Sie auf dem rechten Screenshot.
Das Ergebnis von =SUMME(A1:A2 sehen Sie auf dem rechten Screenshot.

Eine Funktion besteht aus dem groß geschriebenen Namen, danach in Klammern () einzelne Zellen bzw. ein ganzer Zellbereich sowie andere Parameter – jeweils mit ; getrennt. Für einen Zellbereich geben Sie die Koordinaten der ersten und der letzten Zelle an, die berücksichtigt werden sollen, getrennt durch einen Doppelpunkt. Die Formel für das Beispiel ist =SUMME(A1:A2).Sie könnte aber auch =SUMME(A1:A23) heißen oder =SUMME(A:A), wenn die ganze Spalte A addiert werden soll ist. Ohne Funktion wäre dann die Summe schon schwieriger auszurechnen. Am einfachsten erfassen Sie Zellbereiche übrigens, in dem Sie die Zellen beim Erfassen der Formel mit der Maus markieren, statt die Zellbezüge einzutippen.

Auf der nächsten Seite erklären wir " Komplexe Funktionen".